Configuration 2006.11.29.12.47.06.N.2, Device R3!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
no network-clock-participate slot 1 
no network-clock-participate wic 0 
no aaa new-model
ip subnet-zero
!
!
ip nbar port-map ftp tcp 20 21 
ip dhcp excluded-address 180.40.7.131 180.40.7.134
!
ip dhcp pool Prob15
   network 180.40.7.128 255.255.255.224
   default-router 180.40.7.132 
   domain-name cciestudent.com
   dns-server 208.28.1.82 
   option 150 ip 20.20.20.20 
!
ip dhcp pool ForR4
   host 180.40.7.130 255.255.255.224
   client-identifier 0100.0196.de25.80
!
ip dhcp pool ForR3
   host 180.40.7.129 255.255.255.224
   client-identifier 0100.127f.8d1e.a0
!
ip cef
no ip domain lookup
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
track 3 ip route 20.10.2.0 255.255.255.0 reachability
!
track 4 ip route 20.10.1.0 255.255.255.0 reachability
!
!
!
class-map match-all dscp26
  match  dscp af31 
class-map match-all dscp14
  match  dscp af13 
class-map match-all telnet
  match protocol telnet
class-map match-all ef
  match  dscp ef 
class-map match-all dscp12
  match  dscp af12 
class-map match-all dscp28
  match  dscp af32 
class-map match-all prec3
  match ip precedence 3 
class-map match-all ftp
  match protocol ftp
!
!
policy-map test
  class dscp12
  class dscp14
  class dscp26
  class dscp28
  class prec3
  class ef
policy-map Prob711
  class dscp12
   priority percent 25
  class telnet
   bandwidth remaining percent 24
  class ftp
   bandwidth remaining percent 51
  class class-default
   bandwidth remaining percent 25
!
! 
!
!
!
!
interface FastEthernet0/0
 ip address dhcp client-id FastEthernet0/0
 ip policy route-map Prob1
 speed auto
 duplex auto
 vrrp 47 ip 180.40.7.133
 vrrp 47 priority 150
 glbp 47 ip 180.40.7.134
 glbp 47 weighting track 2 decrement 100
 glbp 47 weighting track 4 decrement 100
 standby 47 ip 180.40.7.132
 standby 47 priority 150
 standby 47 preempt
 standby 47 track Serial1/0 51
 standby 47 track Serial1/2 51
 standby 47 track 3 decrement 60
 service-policy input test
 no shutdown
!
interface BRI0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface Serial1/0
 ip address 180.40.7.66 255.255.255.224
 encapsulation frame-relay
 ip ospf network broadcast
 frame-relay map ip 180.40.7.65 307 broadcast tcp header-compression connections 20
 frame-relay map ip 180.40.7.67 302 broadcast
 no shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 ip address 180.40.7.1 255.255.255.224
 max-reserved-bandwidth 100
 service-policy output Prob711
 no shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
interface Serial1/4
 no ip address
 shutdown
!
interface Serial1/5
 no ip address
 shutdown
!
interface Serial1/6
 no ip address
 shutdown
!
interface Serial1/7
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
ip http server
no ip http secure-server
!
ip access-list extended Prob1a
 permit icmp host 100.1.1.1 host 20.10.1.2 echo
ip access-list extended Prob1b
 permit icmp host 100.1.1.1 host 20.10.1.1 echo
ip access-list extended Prob1c
 permit icmp host 100.1.1.1 20.10.1.0 0.0.0.255 echo
!
!
route-map Prob1 permit 10
 match ip address Prob1c
 match length 1001 2147483647
 set interface Serial1/2
!
route-map Prob1 permit 20
 match ip address Prob1a
 set ip next-hop 180.40.7.67
!
route-map Prob1 permit 30
 match ip address Prob1b
 set ip next-hop 180.40.7.2
!
route-map Prob1 permit 40
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 privilege level 15
 no login
!
!
end