Configuration 2006.11.29.12.47.06.N.2, Device R7!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 1 
no network-clock-participate wic 0 
no aaa new-model
ip subnet-zero
!
!
ip nbar port-map ftp tcp 20 21 
!
ip cef
no ip domain lookup
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
track 1 ip route 20.10.1.0 255.255.255.0 reachability
!
!
!
class-map match-all telnet
  match protocol telnet
class-map match-all S5Other
  match access-group name S5
class-map match-all S5Telnet
  match access-group name S5
  match protocol telnet
class-map match-any sql
  match protocol sqlnet
  match protocol sqlserver
class-map match-all Prob21and22
  match access-group name Prob21and22
  match class-map sql
class-map match-any JPG
  match protocol http url "*.jpg"
  match protocol http url "*.jpe"
  match protocol http url "*.jpeg"
  match protocol http mime "*jpeg"
  match protocol http mime "*jpe"
  match protocol http mime "*jpg"
class-map match-all ftp
  match protocol ftp
!
!
policy-map Prob5
  class JPG
   shape average 1000000
  class S5Telnet
   bandwidth 1000
  class S5Other
   police 5000000 conform-action set-prec-transmit 3 exceed-action set-prec-transmit 1
  class class-default
policy-map Prob20to22
  class Prob21and22
   priority 56 128
  class ftp
   bandwidth remaining percent 25
  class telnet
   bandwidth remaining percent 25
  class class-default
   fair-queue 512
policy-map Prob23and24
  class ftp
   police 256000
  class telnet
   police cir 56000 bc 1400 be 3500
     conform-action set-prec-transmit 1
     exceed-action set-prec-transmit 0
     violate-action drop 
  class class-default
   fair-queue
   queue-limit 100
   police 512000
!
! 
!
!
!
!
interface FastEthernet0/0
 ip address 208.28.1.1 255.255.255.0
 speed auto
 half-duplex
 max-reserved-bandwidth 100
 service-policy output Prob20to22
 no shutdown
!
interface BRI0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 ip address 180.40.7.131 255.255.255.224
 ip helper-address 180.40.7.66
 speed auto
 half-duplex
 vrrp 47 ip 180.40.7.133
 glbp 47 ip 180.40.7.134
 glbp 47 weighting track 1 decrement 100
 standby 47 ip 180.40.7.132
 standby 47 preempt
 service-policy output Prob5
 no shutdown
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
 frame-relay interface-queue priority
 no shutdown
!
interface Serial1/0.1 point-to-point
 ip address 180.40.7.65 255.255.255.224
 ip ospf network broadcast
 ip ospf priority 0
 frame-relay class Prob23and24
 frame-relay interface-dlci 703   
 frame-relay ip tcp header-compression passive
 no shutdown
!
interface Serial1/0.2 point-to-point
 ip address 180.40.7.161 255.255.255.224
 ip helper-address 208.28.1.99
 frame-relay priority-dlci-group 1 702 702 702 702
 frame-relay interface-dlci 702 protocol ip 180.40.7.162
 no shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
interface Serial1/4
 no ip address
 shutdown
!
interface Serial1/5
 no ip address
 shutdown
!
interface Serial1/6
 no ip address
 shutdown
!
interface Serial1/7
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
ip http server
no ip http secure-server
!
ip access-list standard S5
 permit 208.28.1.2
!
ip access-list extended Prob21and22
 permit ip host 87.23.11.123 any
 permit ip any host 87.23.11.123
!
!
map-class frame-relay Prob6
 frame-relay priority-group 1
!
map-class frame-relay Prob23and24
 frame-relay cir 600000
 service-policy output Prob23and24
priority-list 1 protocol ip high tcp telnet
priority-list 1 protocol ip low tcp www
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 privilege level 15
 no login
!
!
end